Running netsurf 3.3 on Raspberry Pi in framebuffer

Karel Mácha karel.macha at karlitos.net
Thu Jun 4 11:02:34 BST 2015


Hello,

I would like to try the latest netsurf-browser on my Raspberry Pi. I am using the Raspbian (Debian) distro. I followed the steps on http://source.netsurf-browser.org/netsurf.git/plain/Docs/QUICK-START and build the netsurf browser according to this How-To. In the last step I used:

make TARGET=framebuffer

to build the framebuffer front end. 

But, if i try to run the netsurf browser with ./nsfb -v I get following errors:

(0.000003) desktop/netsurf.c:157 netsurf_init: NetSurf version '3.4 (Dev)'
(0.002204) desktop/netsurf.c:161 netsurf_init: NetSurf on <Linux>, node <kivypie>, release <3.18.9+>, version <#768 PREEMPT Sun Mar 15 18:59:03 GMT 2015>, machine <armv6l>
(0.004817) utils/messages.c:152 messages_load: Loading Messages from '/home/sysop/dev-netsurf/workspace/netsurf/!NetSurf/Resources/en/Messages'
(0.033929) image/image_cache.c:378 image_cache_init: Image cache initilised with a limit of 3145728 hysteresis of 629145
(0.046726) render/html_css_fetcher.c:64 html_css_fetcher_initialise: html_css_fetcher_initialise called for x-ns-css
(0.051498) content/fetchers/curl.c:1239 fetch_curl_register: curl_version libcurl/7.26.0 OpenSSL/1.0.1e zlib/1.2.7 libidn/1.25 libssh2/1.4.2 librtmp/2.3
(0.083398) utils/useragent.c:68 user_agent_build_string: Built user agent "NetSurf/3.4 (Linux)"
(0.085862) content/fetchers/curl.c:1325 fetch_curl_register: cURL linked against openssl
(0.089008) content/fetchers/curl.c:115 fetch_curl_initialise: Initialise cURL fetcher for http
(0.090500) content/fetchers/curl.c:115 fetch_curl_initialise: Initialise cURL fetcher for https
(0.090837) content/fetchers/data.c:65 fetch_data_initialise: fetch_data_initialise called for data
(0.100393) content/llcache.c:3296 llcache_initialise: llcache initialising with a limit of 9437184 bytes
(0.162072) javascript/jsapi.c:46 js_initialise: New runtime handle 0x47c068
(0.164048) framebuffer/gui.c:455 process_cmdline: argc 1, argv 0xbea79804
(0.166074) framebuffer/framebuffer.c:400 framebuffer_initialise: The sdl surface is not available from libnsfb

Am I missing something or do I get the error because of the 3.4 (Dev) version ? Can someone please give me a hint how to fix this ?

+ --------------------------
+  Karel Mácha
+  www.karlitos.net
+ --------------------------





More information about the netsurf-users mailing list