Allrecipes website

Peter Slegg p.slegg at scubadivers.co.uk
Wed May 14 22:05:54 BST 2014


>>> I am using the Atari build No. 1841 (m68k) and this allrecipes page just
>>> displays blank.
>>
>>That build is a little behind but it does not seem to matter, current
>>HEAD on gtk on Linux builds is also empty. Please can you submit a bug
>>report to the tracker [1]
>>
>>>
>>> It is probably just the JS but I can't test that here. I tried editing
>>> the page source to remove the JS but still blank.
>>
>>There is a lot of JS on that page but its failing to display the
>>noscript with it turned off so something else is wrong.
>
>Thanks.
>
>Reported:
>
>http://bugs.netsurf-browser.org/mantis/view.php?id=2116
>
>Peter

I tried a chop search on the page body but it made no difference.

Next I deleted the first few lines inside the <head> and the page
then renders.

These are the deleted lines:

<style id="antiClickjack">body{display:none !important;}</style>
        <script type="text/javascript">
            if (self === top) {
                var antiClickjack = document.getElementById("antiClickjack");
                antiClickjack.parentNode.removeChild(antiClickjack);
            } else {
                top.location = self.location;
            }
        </script>



Peter






More information about the netsurf-users mailing list