libnsfb issue

John-Mark Bell jmb at netsurf-browser.org
Fri Nov 12 20:09:57 GMT 2010


On Thu, 2010-11-11 at 17:07 +0000, Ario K wrote:
> Friendly Greetings,
> I've been trying to compile NetSurf for Linux frambuffer but the
> libnsfb is giving me nightmares. libnsfb seems to be a broken package
> with lots of files (like SDL.h or xcb files)  missing. I downloaded
> many of the missing files but it still wants more. Currently the error
> message is like this:

LibNSFB depends on you having installed the SDL and XCB development
packages on your system. It sounds very much like you have not done so.
You certainly shouldn't be downloading individual header files.

> My distro is Debian Squeeze. Please help me.

In which case, 

apt-get install libsdl-dev libxcb1-dev libxcb-image0-dev \
libxcb-icccm1-dev libxcb-keysyms1-dev

is probably all you need.




More information about the netsurf-users mailing list