National Rail Enquiries site no longer works

Dr Peter Young pnyoung at ormail.co.uk
Sun Dec 27 08:45:36 GMT 2009


On 27 Dec 2009  Roger Darlington <rogerarm at freeuk.com> wrote:

> On 26 Dec 2009, Dr Peter Young wrote:
>> On 18 Dec 2009  Matthew Somerville <matthew at dracos.co.uk> wrote:
>> 
>>> Jim Nagel wrote:
>> 
>>>>>>> http://www.traintimes.org.uk/
>>>>>>> ... Hmm, looks like it's encoding a trailing space into the URL it
>>>>>>> gets redirected to.  Try removing any instance of %20 in the URL it
>>>>>>> sends when you to when you submit the form.
>> 
>>>> contact him about this %20 problem via the link at top right of page.
>> 
>>> I've fixed the encoding of spaces in the station names, which I think is
>>> what's being referred to here. Thanks for letting me know.
>> 
>> Unfortunately not working for me here; RISC OS 5.13 and NetSurf test
>> build r9725. I get the "&20"s not in the station names, but between
>> the date and time in the URL. Till today, I could manually edit these
>> out and get a result, but now if I try this, they immediately go back
>> in again!
>> 
>> Thanks for your work, Matthew, on a very useful site.
>> 

> Have you tried again Peter?

> Matthew modified it yesterday because I was getting %20's between the
> station name and the date.

> Yesterday, he modified it to remove all spaces, wherever they occurred
> in the entry fields.

> It works fine for me now (Netsurf r8643, being the last one before it
> gobbles up memory).

Yes, working now, and wasn't yesterday. Thanks to Matthew for doing 
it, and to Roger for pointing this out.

With best wishes,

Peter.

-- 
Peter, \  /      zfc Yb       \     Prestbury, Cheltenham,  Glos. GL52
Anne    \/ __            __    \                              England.
and     / /  \ | | |\ | /  _    \      http://pnyoung.orpheusweb.co.uk
family /  \__/ \_/ | \| \__/     \______________ pnyoung at ormail.co.uk



More information about the netsurf-users mailing list