[Netsurf-develop] Re: [Netsurf-develop] Petit problème avec sourceforge (was: Minor problem with sourceforge)

Stefaan Claes sclaes at riscosusers.be
Sat Oct 1 22:12:29 BST 2005


On 26 Sep, John-Mark Bell <jmb202 at ecs.soton.ac.uk> wrote:

>  On Mon, 26 Sep 2005, Stefaan Claes wrote:

> > On 22 Sep, Wim Ekels <wim at ekels.nl> wrote:
> > 
> > [snip SF sending the French webpage]
> > 
> > > Same happening here :-(
> > 
> > > The language for the programm is set to  Nederlands, but I'm redirected
> > > to the French page too.
> > 
> > If the Accept language is set to anything but English or German
> > (Deutsch), then NS fetches the French page. Maybe the list of available
> > languages is searched alphabetically and because French is the last
> > possibility, it is selected. It's not that important, but IMHO this isn't
> > very logical.

> Well, it's rather difficult to determine exactly what is going on here. 
> I'm 90% certain that the issue is not with NetSurf. The NetSurf website 
> uses a PHP script to determine the fallback page to send if the 
> appropriate language variant is not available. It appears that something 
> has changed on the server which is preventing this script being run.

It's even more strange than I thought: if I go to the builds webpage
(<http://netsurf.sourceforge.net/builds/>) then I get this webpage in
French. But if I go to <http://netsurf.sourceforge.net/>, then I get the
German version of that webpage.

FWIW I have submitted this to the SF tracker (request ID 1310487, 'Strange
selection of language')


Stefaan

-- 
Stefaan Claes, Hove, Antwerpen, Belgium, Europe, <sclaes at riscosusers.be>




More information about the netsurf-users mailing list