[Netsurf-develop] Incompatibility between NetSurf and RiScript

John-Mark Bell jmb202 at ecs.soton.ac.uk
Sat Dec 24 22:09:47 GMT 2005


On Sat, 24 Dec 2005, Dave Higton wrote:

> In message <456bfcdd4d.druck at druck.freeuk.net>
>          "David J. Ruck" <druck at druck.org.uk> wrote:
>
>>
>> On 23 Dec 2005 Dave Higton <davehigton at dsl.pipex.com> wrote:
>>> If RiScript is already running when I try to run NetSurf, I get an
>>> error message written over the screen: "UnixLib detected recursion
>>> of signal SIGSEGV.  Exiting." and an hourglass that doesn't go
>>> away.  If I quit RiScript, the hourglass stops, and I can then
>>> run NetSurf without an error.
>>
>> Google groups search for "NetSurf RiScript"
>
> 8 hits; none of them describes symptoms remotely resembling mine.

Funny; Peter Young's first post in the first thread there describes 
symptoms very like yours.

> Any more ideas?

Yes; there's a workaround for this in CVS. RUfl will now ignore fonts 
generated by RiScript[1] or fonts in the !TeXFonts resource (one of which 
causes the Font Manager to hang the machine).

This will make its way onto the autobuilder in due course, but I wouldn't 
expect it this side of Christmas ;)


John.

1. I believe that RiScript allows the user to configure where
    auto-generated fonts are stored. RUfl currently checks for "!RiScript"
    occurring in the path to the font data. This will work for RiScript's
    default generated font location but is not guaranteed to do so if you
    use the aforementioned configuration option.




More information about the netsurf-users mailing list