[Netsurf-develop] RISC OS test binary

Philip Ludlam philip at philipnet.com
Mon Jun 24 19:06:11 BST 2002


In message <16d1bf4a4b.james at a7000.strcprstskrzkrk.co.uk> you wrote:

>Something for the testers: I've compiled netsurf for RISC OS:
>To test it, drag the Next slot to at least 800K and type
>*netsurf test1 test1css
>at F12 or in a taskwindow. Lots of text will scroll past. The last line
>should be
>rect 0 601 49 0 "" "span" ""
>You can also try it with different HTML files with the same CSS. If
>you get it to crash or test1 doesn't give the line above, let me know
>here.

test1 works fine here.

However I get the (snipped) output from it with the index page from:
http://www.philipnet.com

==
*netsurf index test1css
Parsing html...
index:34: error: htmlParseEntityRef: expecting ';'
<td width=44><a href="http://www.vigay.com/cgi-bin/webring?ring=riscos&comman

[snip]

Parsing css...
XML tree to box tree...

[snip]

Layout document...
layout.c:472: failed assertion `c->type == BOX_TABLE_CELL'

Unexpected termination (e.g. abort() function)

Postmortem requested
39f6940 in shared library function
39f69e4 in shared library function
39f8918 in shared library function
3d8dc in function __eprintf
f6d8 in anonymous function
e66c in anonymous function
e1ec in anonymous function
e5c4 in anonymous function
e1ec in anonymous function
e040 in anonymous function
8db8 in anonymous function
3a15f10 in unknown procedure
80d8 in function ___init
==

There were several other "htmlParseEntityRef: expecting ';'" errors
relating to the webring URLs. I'm not sure why it's reporting them
though.

Yours,

Phil L.





More information about the netsurf-users mailing list