Building for RISC OS

Dave Higton dave at davehigton.me.uk
Thu Sep 3 21:48:23 BST 2015


In message <55E6290A.6010408 at netsurf-browser.org>
          John-Mark Bell <jmb at netsurf-browser.org> wrote:

> On 01/09/15 21:56, Dave Higton wrote:
> 
> > It all went well until some way into the build itself:
> > 
> > riscos/bitmap.c:33:18: fatal error: rufl.h: No such file or directory
> > 
> > Indeed find can't find rufl.* in the workspace folder.
> > 
> > I didn't see any message flash past earlier about any missing files - but
> > that's no surprise, there's lots of text, only a small window, and slow
> > eyes watching.
> > 
> > Any suggestions?
> 
> This means you didn't set TARGET_ABI before sourcing env.sh, so it only 
> fetched the libraries needed for building for amd64. You need to do:
> 
> TARGET_ABI=arm-unknown-riscos source env.sh ns-pull-install
> 
> Then build NetSurf again with "make TARGET=riscos".

Same result again.

I know I set TARGET_ABI twice - I remember thinking that it was curious
to have to issue the same command twice.

There is an error at the ns-pull-install stage:

make: *** /home/david/dev-netsurf/workspace/librufl: No such file or
directory. Stop.

Aha.  Manually creating the librufl folder has moved it on one:

make: *** No rule to make target 'install'. Stop.

And "make TARGET=riscos" still stops, complaining it can't find
rufl.h.

There are earlier complaints relating to PKG_CONFIG_PATH and no
package 'check'.

Perhaps I need to go back to the start.  "source env.sh" was not
executed as root - could that be the cause?

Dave

____________________________________________________________
Can't remember your password? Do you need a strong and secure password?
Use Password manager! It stores your passwords & protects your account.
Check it out at http://mysecurelogon.com/manager



More information about the netsurf-dev mailing list