Weird text alignment problem

Bernd Roesch nospamname at gmx.de
Tue Mar 29 20:05:10 BST 2011


Hello Chris

On 29.03.11, you wrote:

> Hi all
> 
> My port of NetSurf seems to be afflicted with a strange text alignment
> problem.  As far as I can tell, it is related to superscripted
> text and whether it is a link or not.

The SDL Port have same Problem.

> 
> On http://www.amigans.net the page numbers for threads are shown thus:
> Thread title [1] [2] [3]
> 
> Where the links ("Thread title", "1", "2" etc) are shown in what I
> believe to be the correct position, and the brackets are shown
> superscripted.  Please see attached screenshot :)
> 
> I've checked another browser and the GTK version of NetSurf, and both
> show all the text at the same vertical offset - so I think it's
> something to do with my text positioning code.
> 
> It's very rare to see this - normal links in text are fine - so maybe
> that is supposed to be superscripted?  Although if that is the case,
> why aren't the links?
> 
> Another example is "citation needed" on Wikipedia, which does exactly
> the same on OS4 NetSurf, but shows completely superscripted on another
> browser.  (I haven't checked GTK NetSurf yet - there's a "citation
> needed" at the end of "Grid Squares" on
> http://en.wikipedia.org/wiki/Milton_Keynes for reference - and I've
> attached a screenshot of this too)
> 
> Anybody have any idea what might be causing this or how I might go
> about fixing it?
> 
> Chris
Regards




More information about the netsurf-dev mailing list