[lowrisc-dev] What do you use Debian for (in lowrisc)?

Dr Jonathan Kimmitt jrrk2 at cam.ac.uk
Fri Dec 28 10:02:25 GMT 2018


Dear Manuel,

Have a prosperous New Year. I tried your latest Debian instructions 
today but there is

still a bootstrap fail due to libudev.so.1 being linked against

/lib/riscv64-linux-gnu/libc.so.6: version `GLIBC_2.28'.

The version on the system is 2.27-5. This seems to be the relevant 
extract from debootstrap.log, which follows:

_________________________________________________________

Setting up libapt-pkg5.0:riscv64 (1.8.0~alpha3) ...
dpkg: libudev1:riscv64: dependency problems, but configuring anyway as 
you requested:
  libudev1:riscv64 depends on libc6 (>= 2.28); however:
   Version of libc6:riscv64 on system is 2.27-5.

Setting up libudev1:riscv64 (240-2) ...
dpkg: bsdutils: dependency problems, but configuring anyway as you 
requested:
  bsdutils depends on libsystemd0.

Setting up bsdutils (1:2.33-0.2) ...
Setting up mount (2.33-0.2) ...
dpkg: libsystemd0:riscv64: dependency problems, but configuring anyway 
as you requested:
  libsystemd0:riscv64 depends on libc6 (>= 2.28); however:
   Version of libc6:riscv64 on system is 2.27-5.

Setting up libsystemd0:riscv64 (240-2) ...
dpkg: e2fsprogs: dependency problems, but configuring anyway as you 
requested:
  e2fsprogs depends on libext2fs2 (= 1.44.5-1).

Setting up e2fsprogs (1.44.5-1) ...
Setting up sysvinit-utils (2.93-2) ...
Setting up apt (1.8.0~alpha3) ...
/usr/bin/apt-config: /lib/riscv64-linux-gnu/libc.so.6: version 
`GLIBC_2.28' not found (required by /lib/riscv64-linux-gnu/libudev.so.1)
/usr/bin/apt-config: /lib/riscv64-linux-gnu/libc.so.6: version 
`GLIBC_2.28' not found (required by /lib/riscv64-linux-gnu/libudev.so.1)
/usr/bin/apt-config: /lib/riscv64-linux-gnu/libc.so.6: version 
`GLIBC_2.28' not found (required by /lib/riscv64-linux-gnu/libudev.so.1)

Regards,

Jonathan

On 18/12/2018 22:02, Manuel A. Fernandez Montecelo wrote:
> 2018-12-11 23:30 Karsten Merker:
>> On Wed, Nov 07, 2018 at 11:47:25PM +0100, Karsten Merker wrote:
>>
>> I just wanted to provide a short status update:
>>
>> [...]
>> - There are some positive news regarding libffi: We now have a
>>  backport of the RISC-V support from libffi7 to libffi6 and are
>>  working on removing all dependencies on libffi7 from the archive.
>>  This requires re-building quite a number of packages, which
>>  will take some time and cause some packages to be temporarily
>>  uninstallable during the transition, but once the transition is
>>  complete, it should be possible to use debootstrap without any
>>  further manual intervention.
>
> The transition to libffi6 (version 3.2.1) that Karsten mentions is not
> completely finished, but a few days ago we got past the point when
> debootstrap works straight away with variant "minbase" [1].
>
> So this command should get a basic chroot without any other
> complications [2].  From a Debian system with packages "debootstrap" and
> "debian-ports-archive-keyring" installed:
>
>  debootstrap --variant=minbase --keyring \
>    /usr/share/keyrings/debian-ports-archive-keyring.gpg \
>    unstable TARGET_DIR \
>    http://deb.debian.org/debian-ports/
>
> Or this if not in a Debian system or is not desired to check the
> signature (not recommneded, but well...):
>
>  debootstrap --variant=minbase --no-check-gpg \
>    unstable TARGET_DIR \
>    http://deb.debian.org/debian-ports/
>
>
> Then, making sure that /etc/apt/sources.list contains both entries
> ("unstable" can be "sid", it's an alias):
>
>  deb http://ftp.ports.debian.org/debian-ports/ unstable main
>  deb http://ftp.ports.debian.org/debian-ports/ unreleased main
>
>
> And then "apt update" and "apt install iproute2" and anything else that
> it's deemed necessary.  openssh-server recommended as one of the first
> things to install, to have remote access and better terminal handling
> than the local consoles / ttys.
>
> Hope that helps!
>
>
> [1] There's a problem with with some other packages depending on libelf
>    (IIRC iproute2) that it's still on a separate archive that makes,
>    but this one can simply be installed later, it's not critical like
>    libffi6 affecting apt.
>
> [2] Things might break from time to time due to new upstream uploads or
>    transition, it's "Debian unstable" after all...
>



More information about the lowrisc-dev mailing list