[lowrisc-dev] Having troubles booting lowRISC v0.5

Dr Jonathan Kimmitt jrrk2 at cam.ac.uk
Tue Apr 10 08:45:57 BST 2018


I'm pleased you got it working but the issue you are having is not 
entirely explained by capacity. I have achieved success with a claimed 
32GB Samsung SD-card (recognised as 29.8GB mmc0:59b4) by Linux.

I can believe that different manufacturers would have different 
compatibility issues, because each make of SD-card has its own processor 
and associated eccentricities. The specification tries to hide the 
discrepancies of the medium behind a uniform interface with greater or 
lesser success. The cheaper cards are optimised for MSDOS filing system 
use, so can struggle with ext3 or swap usage.

As an academic project we do not have the resources to test every 
possible card that users might want to use. But the benefits of choosing 
a low cost commodity board outweigh any concerns with signal integrity. 
These factors would have to be investigated more carefully if an 
end-user wanted to commercialise the project.

On 10/04/18 07:15, Chen Dongwei wrote:
> I change the SD-card to a smaller 16GB one and I successfully boot to 
> Linux. So I think this issue is caused by the capacity of SD-card.
>
>
> 在 2018/4/7 0:50, Dr Jonathan Kimmitt 写道:
>> I haven't tried that option. Usually sharing the ethernet card 
>> between a VM and a Windows Host causes issues,
>>
>> but you can experiment preferably without NAT to begin with.
>>
>>
>> On 06/04/18 17:47, 陈东维 wrote:
>>> Thanks for the reply.
>>> I first tried SD-card method because I'm running my Ubuntu on a 
>>> VMWare virtual machine and I'm not sure if the NAT between virtual 
>>> machine and host would cause some trouble.
>>> Is there any trick if I use this virtual machine as the NFS server? 
>>> Or do I just need to configure the ip of eth0 and set up NFS server 
>>> according to the tutorial?
>>>
>




More information about the lowrisc-dev mailing list