[lowrisc-dev] Support for Fedora / compressed extension

Alex Bradbury asb at lowrisc.org
Sun Apr 1 21:48:16 BST 2018


On 1 April 2018 at 21:31, Richard W.M. Jones <rjones at redhat.com> wrote:
>
> Hi, I was going to try v0.5 on my Nexys 4 DDR.  However I believe
> that this version doesn't support the Compressed extension.  I
> disassembled the sample bbl and there are no short instructions.
> Is support for the C extension available and/or planned?

Hi Richard,

Thanks for taking a look. You're correct that we're currently based on
an old version of Rocket which doesn't support the compressed
extension - upstream refactorings have made it difficult to keep up to
date. We do intend to support the C extension, though I can't give a
ETA right now. Sadly this means we can't (for now) directly consume
the awesome work you and your colleagues have been doing on Fedora
RISC-V - but look forward to doing so in the not too distant future.

Best,

Alex



More information about the lowrisc-dev mailing list