[lowrisc-dev] Support for Fedora / compressed extension

Dr Jonathan Kimmitt jrrk2 at cam.ac.uk
Sun Apr 1 21:46:32 BST 2018


Dear Richard,
  The version of Rocket used in lowRISC was forked from an old version of Rocket before the compressed instructions were added. Because of the security extensions we have added it would not be easy to merge the pipeline from a newer Rocket. For the same reason debugging via JTAG is not available. I have never tried the tool chain under Fedora, it is not a Xilinx supported platform by it can be tried if you read the notes on our website concerning LD_LIBRARY_PATH

Sent from my iPhone

> On 1 Apr 2018, at 21:31, Richard W.M. Jones <rjones at redhat.com> wrote:
> 
> 
> Hi, I was going to try v0.5 on my Nexys 4 DDR.  However I believe
> that this version doesn't support the Compressed extension.  I
> disassembled the sample bbl and there are no short instructions.
> Is support for the C extension available and/or planned?
> 
> Rich.
> 
> -- 
> Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
> Read my programming and virtualization blog: http://rwmj.wordpress.com
> virt-p2v converts physical machines to virtual machines.  Boot with a
> live CD or over the network (PXE) and turn machines into KVM guests.
> http://libguestfs.org/virt-v2v
> 




More information about the lowrisc-dev mailing list