[lowrisc-dev] RISC-V tools build error

Wei Song ws327 at cam.ac.uk
Thu Jul 13 12:22:41 BST 2017


According to the config.log file forwarded to me by Jonathan, I think 
there is some env setting issues on your computer.
Especially these lines in the config.log are problematic:

> configure:2416: gcc  _BMV2_  conftest.c >&5
> gcc: error: _BMV2_: No such file or directory

This _BMV2_ comes from your bash environment?

> ac_cv_env_CPPFLAGS_set=set
> ac_cv_env_CPPFLAGS_value=_BMV2_

Anyway, CPPFLAGS should not be set.

What I noticed from the config.log, you have many EDA tools added into 
the path.
Any one of them may set this CPPFLAG which then causes the configuration 
error.
Personal suggestion is to avoid source all EDA scripts in your default 
bash script.
Only source the script if any tool is needed.
This type of incompatibility is usually the reason to not do so.

-Wei


On 13/07/2017 11:18, Mahesh Dananjaya wrote:
> Hi,
> I am just trying to build the lowrisc on my Ubuntu 14.04. But when I tried
> to build the RISC-V tools as in [1]. I got the following error. I have
> attached the config.log file here. Same thing worked fine in my Ubuntu
> 16.04. But I am trying to use regular flow. Is this something relate to my
> gcc version?.
> Error:
> Configuring project riscv-fesvr
> configure: error: in
> `/home/mahesh/paraqum/repos/lowrisc/lowrisc-chip/riscv-tools/riscv-fesvr/build':
> configure: error: C compiler cannot create executables
> See `config.log' for more details
>
> I appreciate any advice to fix this. Thanks in advance.
>
> [1]http://www.lowrisc.org/docs/untether-v0.2/riscv_compile/




More information about the lowrisc-dev mailing list