[lowrisc-dev] KC705 support

Armia Salib armiasalib at yahoo.com
Mon Aug 21 21:21:54 BST 2017


Hello *,

We bought KC705 board particularly to build a system that is based on LowRISC V0.3 project. We tried to execute "make bitstream" from "lowrisc-chip/fpga/board/kc705", but it gave the following errors:

"""
ERROR: [Synth 8-1031] dii_package is not declared [/home/armia/IntensivateRoot/lowrisc-chip/src/main/verilog/chip_top.sv:3]
ERROR: [Synth 8-1766] cannot open include file consts.vh [/home/armia/IntensivateRoot/lowrisc-chip/src/main/verilog/chip_top.sv:5]
ERROR: [Synth 8-1766] cannot open include file dev_map.vh [/home/armia/IntensivateRoot/lowrisc-chip/src/main/verilog/chip_top.sv:6]
""""

Is KC705 board supported for LowRISC V0.3 and V0.4? I can change "lowrisc-chip/fpga/board/kc705/Makefile" with the msissing files, however, I am not sure if I will face more surprises later. What are other changes you may expect to support KC705?

Best regards,
Armia



More information about the lowrisc-dev mailing list