[lowrisc-dev] ERROR: [Synth 8-439] module 'axi_quad_spi_0' not found [/home/rjones/d/lowrisc-chip/src/main/verilog/chip_top.sv:295]

Richard W.M. Jones rjones at redhat.com
Tue Jul 26 08:39:24 BST 2016


On Mon, Jul 25, 2016 at 10:33:35PM +0100, Richard W.M. Jones wrote:
> On Mon, Jul 25, 2016 at 09:44:55PM +0100, Wei Song wrote:
> > Hello Rich,
> > 
> > It is recommended to use Vivado 2015.4 for the untethered version.
> > I think it might because that the versions of the Xilinx IPs are
> > out-of-dated when using Vivado 2016.2.
> > Although for the axi_quad_spi itself, it actually should be OK.
> > 
> > I would suggest you to manually revise
> > fpba/board/nexys4/script/make_project.tcl
> > Remove all -version argument for create_ip commands.
> > 
> > Then
> > 
> > make cleanall
> > make bitstream
> > 
> > Hopefully this can fix your issue.
> 
> OK.  Actually I had to remove one `-version' option already.
> I'll remove them all and report back tomorrow.

Yes this works now, thanks.

I'll try 0.3 later on.

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-top is 'top' for virtual machines.  Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.
http://people.redhat.com/~rjones/virt-top



More information about the lowrisc-dev mailing list