[PATCH 1/4] Only upgrade an older extlinux configuration if we want one.

Tiago Gomes tiago.gomes at codethink.co.uk
Tue Jun 18 16:26:19 BST 2013


---
 morphlib/exts/rawdisk.write |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/morphlib/exts/rawdisk.write b/morphlib/exts/rawdisk.write
index 62d39b3..a74d690 100755
--- a/morphlib/exts/rawdisk.write
+++ b/morphlib/exts/rawdisk.write
@@ -76,7 +76,8 @@ class RawDiskWriteExtension(morphlib.writeexts.WriteExtension):
         else:
             # we are upgrading and old system that does
             # not have an updated extlinux config file
-            self.install_extlinux(mp)
+            if self.bootloader_is_wanted():
+                self.install_extlinux(mp)
         os.symlink(version_label, default_path)
 
         if self.bootloader_is_wanted():
-- 
1.7.10.4




More information about the baserock-dev mailing list