[PATCH] Make ccache use basenames for repos

Sam Thursfield sam.thursfield at codethink.co.uk
Thu Jan 3 16:40:42 GMT 2013


On 01/03/2013 04:24 PM, Jonathan Maw wrote:
> On 2013-01-03 15:32, Lars Wirzenius wrote:
>> On Thu, Jan 03, 2013 at 03:21:39PM +0000, Jonathan Maw wrote:
>>> I have tried to run ./check to see if this breaks anything. It might
>>> do.In my baserock image, ./check fills up /tmp which causes every
>>> successive test to fail. I would like confirmation of whether my
>>> baserock image is messed-up, or if we have a serious problem.
>>
>> TMPDIR=/src/tmp ./check
>> That should tell your tests to not put stuff into /tmp, and put them
>> into /src/tmp instead. You need to have a /src/tmp directory for this
>> to work. You can use any path, of course.
>
> ./check produced one failure in tests.merging/rename-stratum
> -ERROR: goodbye-stratum.morph was not found in
> TMP/workspace/master/test:morphs at ref
> 48d38ef3f39857d7dba4ed1ffc51653c6bed4906
> +ERROR: stratum goodbye-stratum was added within this branch and
> subsequently edited. This is not yet supported: refusing to merge.
>
> But I had this same failure when I ran ./check from master.

This is another case of me not having sorted the results of a call to 
'glob.glob' in the 'morph merge' code. There's a lesson in there: always 
use sorted(glob.iglob) rather than plain glob.glob, or you will get 
different behaviour depending on what file system you are using!

I'll prepare a patch.

Sam




More information about the baserock-dev mailing list